Install Libreoffice Debian

admin
[ jessie ] [ stretch ] [ stretch-backports ] [ buster ] [ buster-backports ] [ bullseye ] [ sid ] [ experimental ]

Links for libreoffice

Seek for forums and documentation about how install software on GNU/Linux. Nevertheless, try apt-get install libreoffice (you've missed 'install'). Debian 8 is oldstable, Debian 9 is new stable. Consider upgrading your operating system, or download newer LibreOffice from LibreOffice's web site instead of installing version that's in Wheezy. Sep 17, 2020 To get the Libre Office 7.0 DEBs for your Debian PC, launch a terminal window on the Debian desktop. Once the terminal window is open, use the CD command to move the command-line session into the “Downloads” directory on your PC. Then, run the wget command to grab the latest Libre Office DEB release. Jan 12, 2021 LibreOffice is a free and open-source complete office suite for Linux and Windows systems. The latest LibreOffice 7 is available to download and install on Linux system. You can install LibreOffice either using the Debian package available under official PPA or use Snap package to install. Install LibreOffice 6.0 on Ubuntu 18.04, Mint 18.3 & Debian 9 Before anything else, you must first uninstall any pre-existing LibreOffice suite software. Login as root and run, apt purge LibreOffice-core && apt-get autoremove.

Debian Resources:

Download Source Package libreoffice:

Maintainers:

  • Debian LibreOffice Maintainers (QA Page, Mail Archive)
  • Rene Engelhard (QA Page)
  • Chris Halls (QA Page)

Debian Install Libreoffice 6

External Resources:

  • Homepage [www.libreoffice.org]

Similar packages:

Http://help.libreoffice.org/Main_Page– LibreOffice Help

office productivity suite (metapackage)

LibreOffice is a full-featured office productivity suite that providesa near drop-in replacement for Microsoft(R) Office.

This metapackage installs all components of libreoffice:It also recommends additional packages (e.g. fonts) in order to match anupstream LibreOffice install as closely as possible.

You can extend the functionality of LibreOffice by installing thesepackages:

Other Packages Related to libreoffice

  • depends
  • recommends
  • suggests
  • enhances

Libreoffice Update

Install Libreoffice Debian

How To Install LibreOffice 7.1 On Linux Mint, Ubuntu, MX ...

  • dep:libreoffice-avmedia-backend-gstreamer [alpha, hppa, sparc64]
    transitional package for GStreamer backend for LibreOffice
    or libreoffice-avmedia-backend-vlc
    VLC backend for LibreOffice
  • dep:libreoffice-base [not hppa]
    office productivity suite -- database
  • dep:libreoffice-calc
    office productivity suite -- spreadsheet
  • dep:libreoffice-core (= 1:6.0.4-1) [hppa]
    office productivity suite -- arch-dependent files
    dep:libreoffice-core (= 1:6.0.6~rc1-1) [alpha]
    dep:libreoffice-core (= 1:6.1.4-1) [sparc64]
    dep:libreoffice-core (= 1:7.0.4-4) [not alpha, hppa, sparc64]
  • dep:libreoffice-draw
    office productivity suite -- drawing
  • dep:libreoffice-impress
    office productivity suite -- presentation
  • dep:libreoffice-math
    office productivity suite -- equation editor
  • dep:libreoffice-report-builder-bin [not hppa]
    LibreOffice component for building database reports -- libraries
  • dep:libreoffice-writer
    office productivity suite -- word processor
  • dep:python3-uno (>= 4.4.0~beta2)
    Python-UNO bridge

Linux Libreoffice Command

  • rec:fonts-crosextra-caladea
    Serif font metric-compatible with the Cambria font
  • rec:fonts-crosextra-carlito
    Sans-serif font metric-compatible with Calibri font
  • rec:fonts-dejavu
    metapackage to pull in fonts-dejavu-core and fonts-dejavu-extra
  • rec:fonts-liberation
    Fonts with the same metrics as Times, Arial and Courier
  • rec:fonts-liberation2
    Fonts with the same metrics as Times, Arial and Courier (v2)
  • rec:fonts-linuxlibertine
    Linux Libertine family of fonts
  • rec:fonts-noto-core [not alpha, hppa, sparc64]
    'No Tofu' font families with large Unicode coverage (core)
  • rec:fonts-noto-extra [not alpha, hppa, sparc64]
    'No Tofu' font families with large Unicode coverage (extra)
  • rec:fonts-noto-hinted [alpha, hppa, sparc64]
    obsolete metapackage to pull in a subset of Noto fonts
  • rec:fonts-noto-mono
    'No Tofu' monospaced font family with large Unicode coverage
  • rec:fonts-noto-ui-core [not alpha, hppa, sparc64]
    'No Tofu' font families with large Unicode coverage (UI core)
  • rec:fonts-sil-gentium-basic
    smart Unicode font families (Basic and Book Basic) based on Gentium
  • rec:libreoffice-java-common (>= 1:6.0.6~rc1~) [alpha]
    office productivity suite -- arch-independent Java support files
    rec:libreoffice-java-common (>= 1:6.1.4~) [sparc64]
    rec:libreoffice-java-common (>= 1:7.0.4~) [not alpha, hppa, sparc64]
  • rec:libreoffice-librelogo [alpha, hppa, sparc64]
    Logo-like programming language for LibreOffice
  • rec:libreoffice-nlpsolver
    'Solver for Nonlinear Programming' extension for LibreOffice
  • rec:libreoffice-ogltrans [alpha, hppa, sparc64]
    LibreOffice Impress extension for slide transitions using OpenGL
    also a virtual package provided by libreoffice-impress
  • rec:libreoffice-report-builder [not hppa]
    LibreOffice component for building database reports
  • rec:libreoffice-script-provider-bsh
    BeanShell script support provider for LibreOffice scripting framework
  • rec:libreoffice-script-provider-js
    JavaScript script support provider for LibreOffice scripting framework
  • rec:libreoffice-script-provider-python
    Python script support provider for LibreOffice scripting framework
  • rec:libreoffice-sdbc-mysql [not alpha, hppa, sparc64]
    MariaDB/MySQL SDBC driver for LibreOffice
  • rec:libreoffice-sdbc-postgresql
    PostgreSQL SDBC driver for LibreOffice
  • rec:libreoffice-wiki-publisher
    LibreOffice extension for working with MediaWiki articles

How To Install LibreOffice On Ubuntu/Debian/Mint

  • sug:cups-bsd
    Common UNIX Printing System(tm) - BSD commands
  • sug:default-jre [alpha, sparc64]
    Standard Java or Java compatible Runtime
    or java6-runtime
    virtual package provided by default-jre, openjdk-11-jre, openjdk-15-jre, openjdk-16-jre, openjdk-17-jre
    or jre
    Package not available
  • sug:default-jre (>= 2:1.8) [not alpha, hppa, sparc64]
    Standard Java or Java compatible Runtime
    or java8-runtime
    virtual package provided by default-jre, openjdk-11-jre, openjdk-15-jre, openjdk-16-jre, openjdk-17-jre
    or jre
    Package not available
  • sug:firefox-esr
    Mozilla Firefox web browser - Extended Support Release (ESR)
    or thunderbird
    mail/news client with RSS, chat and integrated spam filter support
    or firefox
    Mozilla Firefox web browser
  • sug:ghostscript
    interpreter for the PostScript language and for PDF
  • sug:gnupg
    GNU privacy guard - a free PGP replacement
  • sug:gpa
    GNU Privacy Assistant (GPA)
  • sug:gstreamer1.0-libav
    ffmpeg plugin for GStreamer
  • sug:gstreamer1.0-plugins-bad
    GStreamer plugins from the 'bad' set
  • sug:gstreamer1.0-plugins-base
    GStreamer plugins from the 'base' set
  • sug:gstreamer1.0-plugins-good
    GStreamer plugins from the 'good' set
  • sug:gstreamer1.0-plugins-ugly
    GStreamer plugins from the 'ugly' set
  • sug:hunspell-dictionary
    virtual package provided by hunspell-af, hunspell-an, hunspell-ar, hunspell-be, hunspell-bg, hunspell-bn, hunspell-bo, hunspell-br, hunspell-bs, hunspell-ca, hunspell-cs, hunspell-da, hunspell-de-at, hunspell-de-at-frami, hunspell-de-ch, hunspell-de-ch-frami, hunspell-de-de, hunspell-de-de-frami, hunspell-dz, hunspell-el, hunspell-en-au, hunspell-en-ca, hunspell-en-gb, hunspell-en-us, hunspell-en-za, hunspell-es, hunspell-eu, hunspell-fr-classical, hunspell-fr-comprehensive, hunspell-fr-modern, hunspell-fr-revised, hunspell-gd, hunspell-gl, hunspell-gu, hunspell-gug, hunspell-he, hunspell-hi, hunspell-hr, hunspell-hu, hunspell-id, hunspell-is, hunspell-it, hunspell-kk, hunspell-kmr, hunspell-ko, hunspell-lo, hunspell-lt, hunspell-lv, hunspell-ne, hunspell-nl, hunspell-no, hunspell-oc, hunspell-pl, hunspell-pt-br, hunspell-pt-pt, hunspell-ro, hunspell-ru, hunspell-si, hunspell-sk, hunspell-sl, hunspell-sr, hunspell-sv, hunspell-sw, hunspell-te, hunspell-th, hunspell-tr, hunspell-uk, hunspell-uz, hunspell-vi, myspell-eo, myspell-es, myspell-et, myspell-fo, myspell-fr, myspell-tl
  • sug:hyphen-hyphenation-patterns
    virtual package provided by hyphen-af, hyphen-bg, hyphen-ca, hyphen-cs, hyphen-da, hyphen-de, hyphen-el, hyphen-en-gb, hyphen-en-us, hyphen-es, hyphen-fr, hyphen-gl, hyphen-hr, hyphen-hu, hyphen-id, hyphen-is, hyphen-it, hyphen-lt, hyphen-lv, hyphen-nl, hyphen-no, hyphen-pl, hyphen-pt-br, hyphen-pt-pt, hyphen-ro, hyphen-ru, hyphen-sk, hyphen-sl, hyphen-sr, hyphen-sv, hyphen-uk, hyphen-zu, myspell-et
  • sug:imagemagick
    image manipulation programs -- binaries
    also a virtual package provided by graphicsmagick-imagemagick-compat, imagemagick-6.q16
    or graphicsmagick-imagemagick-compat
    image processing tools providing ImageMagick interface
  • sug:libgl1
    Vendor neutral GL dispatch library -- legacy GL support
  • sug:libofficebean-java [not alpha, hppa, sparc64]
    generic Java Bean wrapper for LibreOffice components
  • sug:libreoffice-gnome [alpha, hppa]
    office productivity suite -- GNOME integration
  • sug:libreoffice-gnome [sparc64]
    office productivity suite -- GNOME integration
    or libreoffice-kde5
    transitional package for LibreOffice 'KDE 5' integration
  • sug:libreoffice-gnome [not alpha, hppa, sparc64]
    office productivity suite -- GNOME integration
    or libreoffice-plasma
    office productivity suite -- some Plasma integration
  • sug:libreoffice-grammarcheck
    virtual package provided by libreoffice-lightproof-en, libreoffice-lightproof-hu, libreoffice-lightproof-pt-br, libreoffice-lightproof-ru-ru
  • sug: libreoffice-help (= 6.0) [alpha, hppa]
    Package not available
    sug: libreoffice-help (= 6.1) [sparc64]
    sug: libreoffice-help (= 7.0) [not alpha, hppa, sparc64]
  • sug: libreoffice-l10n (= 6.0) [alpha, hppa]
    Package not available
    sug: libreoffice-l10n (= 6.1) [sparc64]
    sug: libreoffice-l10n (= 7.0) [not alpha, hppa, sparc64]
  • sug:libreoffice-librelogo [not alpha, hppa, sparc64]
    Logo-like programming language for LibreOffice
  • sug:libreoffice-officebean [alpha, sparc64]
    transitional package for libofficebean-java
  • sug:libsane [alpha, hppa, sparc64]
    API library for scanners [transitional package]
  • sug:libsane1 [not alpha, hppa, sparc64]
    API library for scanners
  • sug:libxrender1
    X Rendering Extension client library
  • sug:myspell-dictionary
    virtual package provided by hunspell-kk, myspell-cs, myspell-da, myspell-de-de-1901, myspell-en-au, myspell-eo, myspell-es, myspell-et, myspell-fa, myspell-fo, myspell-fr, myspell-fr-gut, myspell-ga, myspell-gd, myspell-gv, myspell-he, myspell-hu, myspell-hy, myspell-nb, myspell-nn, myspell-sk, myspell-sq, myspell-tl, myspell-uk
  • sug:mythes-thesaurus
    virtual package provided by mythes-ar, mythes-bg, mythes-ca, mythes-cs, mythes-da, mythes-de, mythes-de-ch, mythes-en-us, mythes-es, mythes-fr, mythes-gl, mythes-gug, mythes-hu, mythes-id, mythes-is, mythes-it, mythes-lv, mythes-ne, mythes-no, mythes-pl, mythes-pt-pt, mythes-ro, mythes-ru, mythes-sk, mythes-sl, mythes-sv, mythes-uk
  • sug: openclipart2-libreoffice
    Package not available
    or openclipart-libreoffice
    clip art for OpenOffice.org/LibreOffice gallery
  • sug:pstoedit
    PostScript and PDF files to editable vector graphics converter
  • sug:unixodbc
    Basic ODBC tools

Download libreoffice

Download for all available architectures
ArchitectureVersionPackage SizeInstalled SizeFiles
alpha(unofficial port)1:6.0.6~rc1-170.0 kB84.0 kB [list of files]
amd641:7.0.4-4200.8 kB219.0 kB [list of files]
arm641:7.0.4-4200.8 kB219.0 kB [list of files]
armel1:7.0.4-4200.8 kB219.0 kB [list of files]
armhf1:7.0.4-4200.8 kB219.0 kB [list of files]
hppa(unofficial port)1:6.0.4-169.4 kB84.0 kB [list of files]
i3861:7.0.4-4200.8 kB219.0 kB [list of files]
m68k(unofficial port)1:7.0.4-4200.8 kB219.0 kB [list of files]
mips64el1:7.0.4-4200.8 kB219.0 kB [list of files]
mipsel1:7.0.4-4200.8 kB219.0 kB [list of files]
ppc64(unofficial port)1:7.0.4-4200.8 kB219.0 kB [list of files]
ppc64el1:7.0.4-4200.8 kB219.0 kB [list of files]
s390x1:7.0.4-4200.8 kB219.0 kB [list of files]
sparc64(unofficial port)1:6.1.4-174.7 kB91.0 kB [list of files]